Thursday, January 5, 2012

SOLVED: hpacucli Error: No controllers detected.

It would seem that HP doesn't care to acknowledge the existence of 3.0 or newer kernels with their array configuration tool hpacucli. The solution is to lie to the tool with a custom uname wrapper that can be found here:

1 comment:

jostmart said...

root@x:~# uname -a
Linux pacman 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:13:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

root@x:~# hpacucli controller slot=0 physicaldrive all show

Smart Array P420i in Slot 0 (Embedded)
array A
physicaldrive 1I:1:1 (port 1I:box 1:bay 1, SAS, 300 GB, OK)
physicaldrive 1I:1:2 (port 1I:box 1:bay 2, SAS, 300 GB, OK)

root@x:~# hpacucli version
ACU CLI Version:
SoulAPI Version: